Debe estar conectado para participar
Buscar en los foros:


 






Uso de Comodín:
*    coincide cualquier número de caracteres
%    coincide exactamente un caracter

[Flash] Problema con boton.

No hay Etiquetas
Entrada
Midle End Level

Stranyer

entradas: 149

15:14 06/01/2008

1

Disculpen si esto no va aqui, pero no se me ocurrio en que otro foro iria.

Lo que quiero hacer, es que al oprimir el button "Enviar" se reproduscan los fotogramas: del 4 al 42.

Nada mas.
Archivo: pesa 100Kb Riendo
http://rapidshare.com/files/81748109/login.rar.html

Por favor, necesito esa ayuda.

Cualquier cosa les dejo mi MSN: Stranyer@gmail.com

Desde ya, muchas gracias.

High End Level

konzerte

entradas: 562

15:30 06/01/2008

2

no lo vi a tu archivo, pero no probaste con go to and play o algo similar… y le pones frame 4

la accion la pones a "on click"

espero que te sirva…

High End Level

sebaocano

entradas: 886

16:10 06/01/2008

3

Al boton le tenes que poner, el codigo (no es exactamente asi, es para que tengas una idea)

on release (gotoandplay 4)

y en el frame 42 le pones un stop().

Midle End Level

Stranyer

entradas: 149

16:13 06/01/2008

4
Cita Iniciado por konzerte
Ver Mensaje
no lo vi a tu archivo, pero no probaste con go to and play o algo similar… y le pones frame 4

la accion la pones a "on click"

espero que te sirva…

El codigo del boton, me quedo asi:

Código PHP:

on (release){

    
login();

    
mensaje_txt.text "conectando...";

}

on (release) {

gotoAndPlay("Escena 1"4);





Ahora el drama, es que al reproducir esos fotogramas (del 4 al 42) no da respuesta en el 42.

Te explico:
Esto es un archivo flash, cuya funcion es consultar a una base de datos. Se colocan los datos (user y pass) y al oprimir "Enviar" se comunica con un archivo PHP, y ese a la base de datos.

Lo tenia andando, pero me exigen, que haga un efecto de Giro (como de papel), entonces al colocar los datos y oprimir el boton "Enviar" tendria que hacer el efecto de giro (4 a 42 frames) y alli presentar la respuesta. Pero no me funciona al usar ese codigo en el boton.
Nose si me explico.

Aca tenes el preview

Desde ya muchas gracias.

Extreme Level

The Big Praf

entradas: 2873

12:52 07/01/2008

5

Lo acabo de ver, pero veo que dice que "error en el script"
Se de flash, pero no lo tengo instalado acá en el laburo, así que mucho no puedo ayudarte.
Por lo que entendí tenes un botón y un clip de película en una pagina web. Al apretar el botón, se debe llamar a la función login (que supongo que es la que se conecta a la base de datos), se cambia el texto de un label a "conectando…" y se debe reproducir el cli de película a partir del fotograma 4.
Esto es así?
Que hace el clip en el fotograma 42?

Lycosa user

ASUS 1000HE – ATOM N280 – 2GB RAM – 10" – 9.5hs bateria

High End Level

konzerte

entradas: 562

13:51 07/01/2008

6

a mi tambien me da error…

segun entiendo, el boton reproduce del fotograma 4 al 42, y al llegar al 42 se consulta la base de datos…

lo que se me ocurre es que pongas todo el codigo directamente en el boton.. lo de reproducir desde el fotograma 4 y tambien lo de consultar a una base de datos… no es muy prolijo pero fijate si con eso anda, para empezar a aislar el problema….