Debe estar conectado para participar
Buscar en los foros:


 






Uso de Comodín:
*    coincide cualquier número de caracteres
%    coincide exactamente un caracter

Error Internet Ubuntu 7.04

No hay Etiquetas
Entrada
Hardcore Extreme Level

Juampi_SoAdNw

entradas: 4054

14:03 17/06/2007

1

Buenas gente!!

Ruego a ver si me pueden ayudar, jeje..

Ayer empezé con Ubuntu 7.04 en versión Live-Cd (más adelante haré una partición y lo instalaré). Aclaró que es la 1º véz que lo uso, por lo tanto Novato al 100%.

Pero como la mayoría no consigo conectarme a Internet.

Tengo un modem/router Huawei SmartAX MT882 conectado via Ethernet provisto por Speedy.

Estuve buscando y buscando en internet (google.com/linux, foros, etc..) y enconté algo pero que no me alcanzó y es esto:

•Para realizar una conexion ADSL debemos ejecutar el siguiente comando desde un terminal:
sudo pppoeconf
Esto nos abre una pantalla azul que nos permitirá en distintos pasos configurar la conexión. Nos pide nombre de usuario que corresponderá al usuario que nos asignó nuestro proveedor y la contraseña. Se da Aceptar en todas las pantallas y finalmente realiza la conexión. Luego la próxima vez que querramos conectarnos sólo nos bastara ejecutar el comando
sudo pon dsl-provider
Y en caso de querer detener la conexión:
sudo poff dsl-provider

El tema es que cuando quiero entrar a Internet, no carga las páginas. Entonces leí que había 2 comandos para que detalle si está todo ok, en este caso escribiendo "plog" en la terminal, y me arroja esto, que por lo que veo hay un error, pero no se que es:

Como información, en configuración de la red, tengo marcado Conexión Alambrica, con dirección DHCP y en Servidores DNS: 192.168.1.1.

Acaso hay algo mal que hice?? o que me falto hacer???

Encontré también un "How To" que es este y también serviria para mi modem/router:

http://www.ubuntu-es.org/node/19203 (pero tengo entendido que es solo para si se conecta via USB, lo cual a mi no me serviria ya que uso Ethernet) Estoy en lo cierto?

Espero me puedan ayudar por favor, ya que me gustó y me quiero adentrar en Linux y aprender a usarlo, pero sin Internet se me complica.

Saludos y gracias desde ya!!!

Hardcore Extreme Level

jack

a

entradas: 6358

21:50 18/06/2007

2

Está bien entrar por DHCP, lo que te faltaría es colocar los DNS correctamente de tu proveedor.
Otra opción es bajarte manualmente éste paquete rp-pppoe e instalarlo manualmente.
http://www.roaringpenguin.com/files/…poe-3.8.tar.gz

Código:
$ tar xzvf rp-pppoe-3.8.tar.gz
$ cd rp-pppoe-3.8/src
$ ./configure && make && sudo make install
$ sudo pppoe-setup

Seguís el asistente y deberías poder conectarte tranquilamente.

. - . - .-

 

Cita Iniciado por MatiiBE
los negros juntan honor x frags.. como nosotros los gamers.. pero ellos lo hacen de verdad…
Hardcore Extreme Level

Juampi_SoAdNw

entradas: 4054

23:03 18/06/2007

3

Hola!

Gracias desde ya por ayudarme…

Y te va a parecer tonto, pero despues de bajar ese archivo, donde lo copio???

Y otra cosita, yo en Servidores DNS no toque nada, lo deje como estaba, y lo que me parecia raro y es por eso que no me funciona internet es el error que me muestra en la terminal: "PAP authentication failed" (fijate que eso dice en la imagen que puse en el posteo con la consulta).

saludos y gracias nuevamente!!

Hardcore Extreme Level

jack

a

entradas: 6358

10:22 19/06/2007

4

El archivito que te dejé copialo a tu home o carpeta de usuario por medio de un pen o diskette.
Después vas a ver que por medio de ese discador sacás andando la conexión.
A mi para conexiones ADSL no me convence mucho el script pppoeconf.

. - . - .-

 

Cita Iniciado por MatiiBE
los negros juntan honor x frags.. como nosotros los gamers.. pero ellos lo hacen de verdad…
Hardcore Extreme Level

Juampi_SoAdNw

entradas: 4054

16:30 19/06/2007

5

Hola de nuevo!!!

Bajé el archivo, lo copie al pendrive y luego lo copié dentro de la carpeta Home en Ubuntu.

Abrí la terminal, e hice lo que me dijiste:

$ tar xzvf rp-pppoe-3.8.tar.gz
$ cd rp-pppoe-3.8/src
$ ./configure && make && sudo make install
$ sudo pppoe-setup

Pero luego de escribir la tercer linea me tira este error:

Y obviamente luego no anda la 4º linea.

Tendras idea que puede ser??

Y respecto a la 1º imagen que puse en este thread, del error ese PAP authentication failed, estuve averiguando y puede ser algo mal configurado??? O con lo que me dijiste vos se solucionaria???

Gracias desde ya nuevamente!!!

Hardcore Extreme Level

jack

a

entradas: 6358

19:03 19/06/2007

6

Ah, ya ta…
Poné el cd de Ubuntu, abrí la terminal y luego tipeá:

Código:
$ sudo apt-cdrom add
$ sudo aptitude install build-essential

Luego repetí los pasos que describí antes.
Sobre el error PAP quizás tenga algo mal ese fichero, pero como te dije antes, como no uso ese script no puedo deducir completamente de que se trata.

Saludos.

. - . - .-

 

Cita Iniciado por MatiiBE
los negros juntan honor x frags.. como nosotros los gamers.. pero ellos lo hacen de verdad…
Hardcore Extreme Level

Juampi_SoAdNw

entradas: 4054

20:53 19/06/2007

7

Hola de nuevo, y perdon por la insistencia:

Hice todo lo que me dijiste:

1º esto (poniendo el cd):

$ sudo apt-cdrom add
$ sudo aptitude install build-essential

2º esto (previo a copiar el archivito a /home):

$ tar xzvf rp-pppoe-3.8.tar.gz
$ cd rp-pppoe-3.8/src
$ ./configure && make && sudo make install
$ sudo pppoe-setup

Hasta ahí todo joya, ningun error, fue aceptando y cargando todo bien.
Y luego de esa ultima linea sigo el asistente completando los datos y termina así:

El tema es que cuando abro el navegador, carga un rato y luego aparece el tipico error de que no abre la página, y que es el problema que tengo desde un principio.

Fijate que en la terminal pruebo que pasa si escribo sudo pppoe-start y ahi ves que dice que parece haber una conexión, pero si luego escribo pppoe-status fijate que hay una especie de error.
Sera ese el problema ahora???

La verdad que pensé que era algo más accesible establecer la conexión
Y veo que no es solo mi caso porque ya me lei demasiada info en varios sitios, y el problema para conectar a internet parece ser demasiado comun.

Pero bua, quizas sepas que es lo que me pasa ahora!!!

Gracias desde ya, y te felicito por los conocimientos que veo tenes y mucho de Linux

Hardcore Extreme Level

jack

a

entradas: 6358

21:20 19/06/2007

8

Tamos cercaaaaaa….
El problema posiblemente sean los DNS. Tenés que poner SI o SI los DNS Primario y Secundario de tu proveedor.
Fijate que acá tenés dos caminos:
- O ejecutar ésto:

Código:
$ cd rp-pppoe-3.8
$ sudo ./go-gui

Y seguir los pasos graficamente, requiere de las librerías tk y tcl, por lo tanto si no las tenés ponés el cdrom de Ubuntu y tipeás:

Código:
$ sudo aptitude install tk tcl

– La otra forma es editar manualmente los archivos resolv.conf, pppoe.conf y pppoe-conf-3.8.

Código:
$ sudo gedit /etc/resolv.conf

Acá tenés que saber cuales son tus DNS:
nameserver DNS 1º
nameserver DNS 2º
Guardás y salís.
Por las dudas pegales una miradita a los archivos que te mencioné más arriba, esos ficheros conf. del demonio ppp.
Están en el directorio /etc/ppp/
Los editás de la misma manera BUSCANDO correctamente el lugar donde debés poner tus DNS, OJO!! Eso solo modificá ahí.

Guardá todo y salí.
Yo creo que con la primera opción e intentado conectar deberías salir a internet.

Saludos.

. - . - .-

 

Cita Iniciado por MatiiBE
los negros juntan honor x frags.. como nosotros los gamers.. pero ellos lo hacen de verdad…
Hardcore Extreme Level

Juampi_SoAdNw

entradas: 4054

14:40 20/06/2007

9

Hola de nuevo!!

A ver..

Hice esto:

$ cd rp-pppoe-3.8
$ sudo ./go-gui

Pero termina así con este error (por lo que no hay ningun paso grafico a seguir):

Luego probe esto:

$ sudo aptitude install tk tcl

Pero volvi a hacer lo anterior y ese error vuelve a aparecer.

Entonces hice estos 3 pasos, editando en cada uno los dns primario y secundario:

$ sudo gedit /etc/resolv.conf

$ sudo gedit /etc/ppp/pppoe.conf

$ sudo gedit /etc/ppp/pppoe.conf-3.8

Y luego de guardar cada uno, entro al navegador de internet y sigue sin cargar las paginas.

Ahora permitime hacerte 2 preguntas:

1. Porque quizas estoy ingresando mal los DNS. Yo con WindowsXP tengo puesto obtener la direccion IP y del servidor DNS automaticamente. Con lo cual para saber cual es, en ejecutar escribo "cmd" para abrir una ventana de DOS, y luego escribo "ipconfig /all". Y ahi me dice todos los datos, que son estos:

Y yo los que pongo en el Ubuntu son los 2 que circule en rojo, esta bien no???

2. Luego de hacer todos los pasos que vos me decis, no falta hacer algo mas?? O sea porque en WinXP antes de abrir una pagina, primero hago click derecho sobre la conexion Speedy que tengo y luego hago click en Conectar, luego OK, y ahi en un par de segundos testea el nombre de usuario y la contraseña y luego se conecta.
En Linux no es asi, no hay que tocar nada en Configuracion de Red, en donde tengo puesto Conexión Alambrica??? Ante todo perdon por esta ignorancia si lo es.

Gracias nuevamente por tu atención prestada!!!!!!!!
Saludos y que sigas bien!!!

Hardcore Extreme Level

jack

a

entradas: 6358

10:58 21/06/2007

10

Posteame tu pppoe-conf y/o pppoe-conf-3.8 si es que tenés éste fichero.
Y los DNS están bien, son esos, por eso mismo vos tenés que poner en la configuración de red como DISABLED la ALAMBRICA.

Después ejecutá el comando:

Código:
$ sudo pppoe-start
. - . - .-

 

Cita Iniciado por MatiiBE
los negros juntan honor x frags.. como nosotros los gamers.. pero ellos lo hacen de verdad…
Extreme Level

CHIPI

entradas: 1586

15:01 21/06/2007

11

No sería más fácil configurar el Router para que se conecte a Internet (ya que tiene soporte PPPOE) y no dependés del S.O???? podés poner cualquier livecd y lo que se te ocurre y vas a tener internet. Yo tengo un Router y me ahorré un millón de quilombos así

Hardcore Extreme Level

Juampi_SoAdNw

entradas: 4054

17:56 21/06/2007

12

Hola, aquí escribiendo desde Ubuntu, jeje.

Al final como no podía hacerlo andar, configure los DNS manualmente desde la Configuracion de Red en Conexion Alámbrica.

Luego en la terminal:

sudo pppoeconf

y sigo el asistente, hasta terminar de poner los datos del proveedor.

Luego escribo en la terminal:

plog

y por suerte dá todo OK.

Entro a Internet y anda todo perfectamente

Y despues se me dió por volver a probar lo que me dijo Jack, solo estos 2 pasos:

$ sudo apt-cdrom add
$ sudo aptitude install build-essential

Y luego esto (copiando antes el archivito que me pasaste):

$ tar xzvf rp-pppoe-3.8.tar.gz
$ cd rp-pppoe-3.8/src
$ ./configure && make && sudo make install
$ sudo pppoe-setup

Y ahora también andubo perfecta la conexión!!!!

Asi que muchisimas gracias JACK, ya que de paso aprendí bastantes comandos!!
Ahora a seguir probando y descubriendo cosas, espero no tener que molestarte mas, aunque lo dudo, jeje!!!

GRACIAS NUEVAMENTE!!!

saludos y suerte!!!

p.d: Por si no te dije, GRACIAS de nuevo, jajaja!!

Hardcore Extreme Level

jack

a

entradas: 6358

19:56 21/06/2007

13

Me alegro que lo hayas podido sacar, como habrás visto es muy fácil con un modem ethernet.
Increiblemente, Linux a veces NO toma los DNS y por eso le cuesta salir andando de una, pero en casos como el tuyo, por medio del discador rp-pppoe es muy sencillo configurar la conexión.
El otro pequeño detalle suele ser la edición de un par de arhivos .conf……pero leyendo y practicando se aprende.

Ahora, el próximo paso es la instalación, el cual también es más sencillo y encima hay varias guías paso a paso en la web para hacerlo.

Saludos.

. - . - .-

 

Cita Iniciado por MatiiBE
los negros juntan honor x frags.. como nosotros los gamers.. pero ellos lo hacen de verdad…