Debe estar conectado para participar
Buscar en los foros:


 






Uso de Comodín:
*    coincide cualquier número de caracteres
%    coincide exactamente un caracter

Problemas con el MBR (Master Boot Record)

No hay Etiquetas
Entrada
Nuevo miembro

megalomano

entradas: 40

20:05 21/10/2007

1

Tengo el problema localizado, pero no termino de aclararme:

Instalé LINUX ubuntu
Lo desistalé
Me "destrozó" el sector de arranque de windows

Para restaurarlo he intentado varias cosas
Reinstalar windows
ir a "restaurar" y hacer un fixmbr y fixboot
Probar con varias herramientas de mbr que no entiendo
reinstalando xp, vista, otra vez xp…

Si entro en el menu de arranque de la placa y selecciono el disco C: funciona perfectamente, e incluso si dejo el CD de instalación de XP, no presiono nada y sigue cargando (porque el cd seleccionará el c tambien entra. Pero cuando arranca solo y sin CD de arranque, fallo de disco, el mbr está muerto.

¿Cual es lo solucion real, verdadera y definitiva? Al final he salido escocido de Ubuntu

Extreme Level

ecibad

entradas: 2730

20:10 21/10/2007

2

tenes que hacer un MBRFIX… con este programita

Saludos.

Pasa y enterate lo que podemos hacer juntos para ganarle a las enfermedades.
Nuevo miembro

megalomano

entradas: 40

20:30 21/10/2007

3

gracias por la velocidad de respuesta. Sigo como loco buscando una solucion. Tan solo te pediria algun detalle de lo que hacer con ese archivo. Imagino que lo tengo que meter en un disquete y meterlo en el arranque

¿que instruccion necesito en concreto? muchas gracias de nuevo.

Extreme Level

ecibad

entradas: 2730

20:39 21/10/2007

4

De nada che.. yo pase por la misma y realmente puede llegar a ser desesperante!… te dejo los pasos a seguir:

1 – Crear un medio booteable.
2 – Correr MbrFix para ver la lista de particiones actual el command seria algo asi: mbrfix /drive 0 listpartitions
3 – Ejecutar este otro comando para inciar el proceso: mbrfix /drive 0 fixmbr
4 – Esto es por si tenes mas de un disco fisico, ahi deberias usar el numero apropiado para cada disco, ejemplo, cambiar el "0" a el numero que corresponda.

Espero te haya sido de utilidad.

Saludos.

Pasa y enterate lo que podemos hacer juntos para ganarle a las enfermedades.
Hardcore Extreme Level

jose_073

entradas: 4258

21:15 21/10/2007

5

Si no más fácil

Hacete un disco de inicio de Windows 98

Que bootee normal, no importa el CDRom acá.

Cuando llegas al prompt (A:\&gtwink escribis

A:\>fdisk /mbr

y listo. Reiniciás y fijate si anda.

Saludos

Miss you: AMD Athlon 4200@2800 1.2v – Biostar TForce 7050 – OCZ Gold 800 CL3 – XFX 9600GT
Nuevo miembro

megalomano

entradas: 40

21:32 21/10/2007

6
Cita Iniciado por jose_073
Ver Mensaje
Si no más fácil

Hacete un disco de inicio de Windows 98

Que bootee normal, no importa el CDRom acá.

Cuando llegas al prompt (A:\&gtwink escribis

A:\>fdisk /mbr

y listo. Reiniciás y fijate si anda.

Saludos

Bueno, he probado las dos cosas y nada. Seguro que es una tonteria, pero no lo encuentro. El mbrfix lo he puesto en marcha desde el simbolo de sistema del menu de opciones de arranque de xp (no se me ocurria otra forma), y el fdisk lo he hecho con un disco de arranque de w98 y cuando lo hago no me dice nada (pero tampoco me da error) el asunto es que sigue dandome el fallo

Se me ha olvidado decir que tengo dos disco en los que toque con linux. Pero imagino que lo importante es que arranque biien el que tiene instalado el xp. SI lo elijo de la lista de opciones del menu especial de la placa entra sin problemas, y el segundo disco lo puedo usar tambien (están los dos como primarios, eso si)

EN el mbrfix creo que ponia que mi disco a modificar era el 1. (Hay alguna otra forma de poner el marcha el mbrfix que no sea como lo he hecho?) EN fin…gracias de nuevo.

Extreme Level

ecibad

entradas: 2730

21:44 21/10/2007

7

Mira, si no lo podes resolver arreglando el MBR.. lamento decirte que deberias formatear tonc.

Saludos.

Pasa y enterate lo que podemos hacer juntos para ganarle a las enfermedades.
Nuevo miembro

megalomano

entradas: 40

21:45 21/10/2007

8

Vale, acabo de descubrir una cosa! he desactivado desde la bios el segundo disco duro y el que tiene el xp instalado HA ARRANCADO SIN PROBLEMAS!. Es decir…es el segundo disco el que interfiere lanzandose prioritariamente en el arranque. ¿Eso tambien tendrá solucion?

Nuevo miembro

megalomano

entradas: 40

22:03 21/10/2007

9

Solucionado!! he convertido en logico el segundo disco. Todo el tema del mbr seguramente habia hecho su papel, pero quedaba esa ultima cosa. Muchas gracias y me voy a la cama que por aquí son las 3 de la madrugada y mañana toca trabajar xD Saludos!