Debe estar conectado para participar
Buscar en los foros:


 






Uso de Comodín:
*    coincide cualquier número de caracteres
%    coincide exactamente un caracter

Uso de Procesador mientras Imprimo

No hay Etiquetas
Entrada
Nuevo miembro

Daniel Caste

entradas: 5

10:10 24/07/2008

1

Hola Gente!!!
Hace 34 años que estoy ganandome la vida con la Informatica ( programador , analista ) en ambientes MainFrame ( los monstruos de IBM ) y lo relacionado a Base de Datos ( Informix , DB2 , Sybase , etc) y por supuesto tengo PC en el laburo y en casa.
Aclarado esto les pregunto:
Por que cuando Windows esta imprimiento en una impresora local lleva el uso de CPU al 100% ???
Por que el periferico mas lento es el que consume mas recursos ????

Atte.:
Daniel.

Midle End Level

Tripen

entradas: 490

14:49 24/07/2008

2

Que impresora es ? Por que por ahi no tiene nada de buffer entonces le tiene q estar mandando datos constantemente. Saludos.

Nuevo miembro

Daniel Caste

entradas: 5

10:07 25/07/2008

3
Cita Iniciado por Tripen
Ver Mensaje
Que impresora es ? Por que por ahi no tiene nada de buffer entonces le tiene q estar mandando datos constantemente. Saludos.

Esto sucede con cualquiera de mis dos impresoras.
HP 610C ( chorro de tinta ) y Epson 810 LQ ( matriz de agujas ).
Ambas conectadas por puerto paralelo.

El tema es que la velocidad de impresion en caracteres/segundo es muy baja para las velocidades de las CPU's actuales como para justificar semejante uso de CPU..

Midle End Level

Tripen

entradas: 490

12:11 25/07/2008

4

Claro pero la velocidad de impresion no tiene nada q ver con la velocidad del procesador, es totalemente independiente. Lo que debe pasar es q el procesador se queda "colgado" con la impresora esperando que le pida mas informacion, fijate si no tenes alguna opcion de en la impresora o en algun lado para que funcione en modo interrupcion. Mucha idea no tengo pero capas q ese es el problema fijate y comenta. Saludos.

High End Level

polosoft

entradas: 998

13:01 25/07/2008

5

El tema es que el puerto paralelo de por si es un medio muy lento (incluso las motherboards ya casi ni lo incluyen). Igual tendrías que verificar en la BIOS que lo tengas como EPP (o probar como ECP, pero no creo que alguna impresora lo haya utilizado así). También la calidad del cable puede influir (si mal no recuerdo un cable EPP bueno tenía las masas individuales). El tema también pasa porque del lado de la PC el hard del puerto es extremadamente simple, no tiene bufers de ningún tipo, o sea que cuando manda datos se queda esperando para ver si se recibieron, tal vez de ahí el 100% de uso (probá si te da la opción de habilitarle una interrupción ).