Debe estar conectado para participar
Buscar en los foros:


 






Uso de Comodín:
*    coincide cualquier número de caracteres
%    coincide exactamente un caracter

problemas con mplayer – pantalla completa

No hay Etiquetas
Entrada
Nuevo miembro

squall_ar

entradas: 4

19:48 13/12/2008

1

buen dia. recien instale el mplayer en ubuntu 8.04 siguiendo estas instrucciones del siguiente link:
http://www.guia-ubuntu.org/index.php?title=MPlayer

la musica y video lo reproduce bien.

http://i16.photobucket.com/albums/b2…mplayer_01.png

el problema es que al tratar de ver el video en pantalla completa se maximiza la ventana pero el video sigue igual.


http://i16.photobucket.com/albums/b2…mplayer_02.png


http://i16.photobucket.com/albums/b2…mplayer_03.png

aqui esta el documento de configuracion (mplayer.conf) :

##################
# video settings #
##################

# Specify default video driver (see -vo help for a list).
vo=xv

# Use SDL video with the aalib subdriver by default.
#vo = sdl:aalib

# FBdev driver:
#
# mode to use (read from fb.modes)
#fbmode = 640x480-120
#
# location of the fb.modes file
#fbmodeconfig = /etc/fb.modes

# Specify your monitor timings for the vesa and fbdev video output drivers.
# See /etc/X11/XF86Config for timings. Be careful; if you specify settings
# that exceed the capabilities of your monitor, you may damage it.
#
# horizontal frequency range (k stands for 1000)
#monitor-hfreq = 31.5k-50k,70k
#
# vertical frequency range
#monitor-vfreq = 50-90
#
# dotclock (or pixelclock) range (m stands for 1000000)
#monitor-dotclock = 30M-300M

# Start in fullscreen mode by default.
#fs=yes

# Change to a different videomode when going fullscreen.
#vm=yes

# Override the autodetected color depth, may need 'vm=yes' as well.
#bpp=0

# Enable software scaling (powerful CPU needed) for video output
# drivers that do not support hardware scaling.
#zoom=yes

# standard monitor size, with square pixels
#monitoraspect=4:3

# Use this for a widescreen monitor, non-square pixels.
#monitoraspect=16:9

# Keep the player window on top of all other windows.
#ontop=yes

##################
# audio settings #
##################

# Specify default audio driver (see -ao help for a list).
ao=pulse,alsa,

# Use SDL audio driver with the esd subdriver by default.
#ao = sdl:esd

# Specify the mixer device.
#mixer = /dev/mixer

# Resample the sound to 44100Hz with the lavcresample audio filter.
#af=lavcresample=44100

# Specify default audio codec (see -ac help for a list).
ac=mad,

##################
# other settings #
##################

# Drop frames to preserve audio/video sync.
#framedrop = yes

# Specify your preferred skin here (skins are searched for in
# /usr/local/share/mplayer/skins/<name> and ~/.mplayer/skins/<name&gtwink.
#skin = Abyss

# Resample the font alphamap.
# 0 plain white fonts
# 0.75 very narrow black outline (default)
# 1 narrow black outline
# 10 bold black outline
#ffactor = 0.75

# cache settings
#
# Use 8MB input cache by default.
#cache = 8192
#
# Prefill 20% of the cache before starting playback.
#cache-min = 20.0
#
# Prefill 50% of the cache before restarting playback after the cache emptied.
#cache-seek-min = 50

# DVD: Display English subtitles if available.
#slang = en

# DVD: Play English audio tracks if available.
#alang = en

# You can also include other configuration files.
#include = /path/to/the/file/you/want/to/include

#Screensaver support (for non gmplayer)
stop-xscreensaver = "yes"

#Disable joystick support
#It seems to cause very odd problems on laptops
#With accelerometers (See LP: #75925)
nojoystick = yes
#
##############################################

tal vez el problema sean las siguientes ordenes:
# mode to use (read from fb.modes)
#fbmode = 640x480-120 =====================> sera otro valor
# standard monitor size, with square pixels
#monitoraspect=4:3 =====================> sera otro valor
# Use this for a widescreen monitor, non-square pixels.
#monitoraspect=16:9 =====================> sera otro valor

como no se configurarlo bien no quisiera alterar los valores. (que tal si lo desconfiguro)

por su ayuda muchas gracias.

High End Level

Kakarottoo

entradas: 503

21:44 13/12/2008

2

Lo tenes configurado para q muestre el tamaño half size. Ponelo en touch windows from inside en el menu video frame.

Nuevo miembro

squall_ar

entradas: 4

21:27 14/12/2008

3

gracias Kakarottoo por contestar, pero no encuentro el menu video frame. los menus a los que puedo accesar/ver son los siguientes:

Midle End Level

_wanako_

entradas: 214

01:40 16/12/2008

4
Código:
##################
# video settings #
##################

# Specify default video driver (see -vo help for a list).
vo=xv    ----> OK

# Start in fullscreen mode by default.
#fs=yes    ----> Iniciar en FullScreen (si te gusta)

# Change to a different videomode when going fullscreen.
#vm=yes    ----> Cambiar los Modos de Video :-)
vm=yes

# Enable software scaling (powerful CPU needed) for video output
# drivers that do not support hardware scaling.
#zoom=yes    ----> Cambiar los Modos de Video por Soft (con un buen cpu) :-)
zoom=yes

Simple, descomentás las opciones que querés quitando el símbolo almohadilla " # ".
Descomentar se dice porque es muy común usar en los archivos de conf este símbolo y cuando un programa lo lee al principio de una línea la ignora, la trata como un comentario, si no querés descomentar podés volver a escribir la opción sin la almohadilla como en el ejemplo anterior…

Salú.

[SIGPIC][/SIGPIC]
MaximoOC: La velocidad del micro será expresada en octavos de milla cada quince días.

Nuevo miembro

squall_ar

entradas: 4

17:02 17/12/2008

5

gracias _wanako_ pero al descomentar me aparece el mplayer en full screen pero el video o la imagen aparece en tamaño normal.

creo que ese es el problema ya que al explicarme el [mode config] y descomentar las opciones en el menu grafico (click con el boton derecho del mouse) siempre estaba seleccionado el modo "normal size" aunque seleccione cualquier otro modo. [half size] [double size] [full screen].

ahora entiendo cuando Kakarottoo menciono que lo tenia seleccionado en half size y tenia que colocar la opcion: touch windows from inside pero lo que no entiendo es donde encuentro el menu "video frame".

en fin, seguiré buscando y si lo soluciono posteo la respuesta aca.

—————————————————————————————————————–
la solucion temporal que encontre fue:

abrir una terminal

escribir lo siguiente:
gmplayer -zoom

y con esto llamo al mplayer y desde ahi selecciono el video que deseo ver, lo abre y selecciono [fullscreen] y ya puedo ver el video a pantalla completa.

el problema es que como lo menciono _wanako_: "Cambiar los Modos de Video por Soft (con un buen cpu) :-)"
el video en algunas partes se detiene y despues se reproduce. seguramente mi cpu no es muy potente. gracias a todos.

pd: ¿como cambio el titulo del mensaje para escribir [resuelto]?