Debe estar conectado para participar
Buscar en los foros:


 






Uso de Comodín:
*    coincide cualquier número de caracteres
%    coincide exactamente un caracter

Pantalla negra (suspendida?) en Debian Etch

No hay Etiquetas
Entrada
Nuevo miembro

ICE-MAN

entradas: 26

12:21 15/03/2008

1

Luego de instalar el DVD me aparece el gestor de arranque GRUB donde aparecen dos opciones.
Selecciono la primera y luego de ver lo que supongo es la carga del sistema operativo se queda la pantalla negra y el led del monitor esta en naranja -como si estuviera suspendido-… pienso que intenta mostrar una resolución que no puede.

El hardware es un trilobite electrónico: Pentium 3 750 Mhz, chipset intel 810.
Antes de instalar, revise las carpetas del DVD de Debian 4.0 r0 "Etch" – Official i386 DVD Binary – 1
me di cuenta que en pool\main\x\server-xorg-video-i810 esta lo que supongo es el controlador para video. Que sucede?

Me dijeron que tengo en entra en la consola e introducir
sudo dpkg-reconfigure xserver-xorg

pero cómo entro en la consola si no veo nada?

Extreme Level

NoName

entradas: 2655

15:11 15/03/2008

2

Si, evedientemente durante la instalación seleccionaste modos que tu config no soporta, proba cambiar la resolución tocando ctrl+alt+el "+" del numbpad, si no funciona hace esto:

Salí al shell pulsando ctrl+alt+F1 y logueate como root.

Código:
# vi /etc/X11/xorg.conf

Ahí dentro fijate que hay una en el bloque Screen que debe contener una subsección como esta:

Código:
SubSection "Display"
      Depth        24
      Modes        "1024x768" "800x600" "640x480"
EndSubSection

Ahi en la linea Modes tenés que agregar resoluciónes soportadas por tu sistema.
Guardá los cambios (si no manejas VI usa cualquier otro editor), reiniciá Xorg (o rebooteá si no sabes como) y probá de nuevo.

Como te dijeron también podés hacerlo con dpkg-reconfigure xserver-xorg, es mucho más simple si no tenés mucha idea pero tenés que configurar todos los parámetros, editandoló a mano podés ir directo al punto.

Linux Registered User #312139 – http://counter.li.org/
Nuevo miembro

ICE-MAN

entradas: 26

10:08 18/03/2008

3
Cita Iniciado por NoName
Ver Mensaje
Si, evedientemente durante la instalación seleccionaste modos que tu config no soporta…

En la instalación no seleccioné nada para la configuración del monitor-placa de video, o no apareció.

Se queda la pantalla negra y el led del monitor esta en naranja -como si estuviera suspendido-, en Windows me sucede lo mismo cuando intento con una resolución que la combinación de monitor-placa de video no puede. La resolución "ideal" es de 800x600 24 bits, 85 Hz.

Midle End Level

_wanako_

entradas: 214

14:50 18/03/2008

4
Cita Iniciado por ICE-MAN
Ver Mensaje
En la instalación no seleccioné nada para la configuración del monitor-placa de video, o no apareció.

Se queda la pantalla negra y el led del monitor esta en naranja -como si estuviera suspendido-, en Windows me sucede lo mismo cuando intento con una resolución que la combinación de monitor-placa de video no puede. La resolución "ideal" es de 800x600 24 bits, 85 Hz.

Bué, tas usando Debian o la porquería de Ubuntu?
Fijate de editar el inicio de Grub "en caliente", cuando inicia te posicionás sobre la primer opción, la segunda por lo general es safe mode o single user, presionás la tecla "e" (editar) y aparecen las opciones que Grub le pasa al kernel, te volvés a posicionar en la línea que contiene la frase "vga=xxx" y volvés a teclear "e" (editar), cambiás vga=xxx por vga=normal o borrás la frase, así no se activa el framebuffer de video, tecleás "b" (bootear) y debería arrancar con resolución de 80x25 caracteres.
Una vez dentro de la consola te ponés a editar lo que quieras en el /etc/X11/xorg.conf

[SIGPIC][/SIGPIC]
MaximoOC: La velocidad del micro será expresada en octavos de milla cada quince días.

Nuevo miembro

ICE-MAN

entradas: 26

10:33 29/03/2008

5

El problema era con Debian Etch, pero con Ubuntu 7.10 no apareció la pantalla negra suspendida.

Favor de cerrar el hilo.