Debe estar conectado para participar
Buscar en los foros:


 






Uso de Comodín:
*    coincide cualquier número de caracteres
%    coincide exactamente un caracter

[Guia] Usar modo AHCI con chipset P35 (ICH9) con windows ya instalado

No hay Etiquetas
Entrada
High End Level

BiFa

entradas: 764

22:55 19/05/2008

1

Como no vi que esto este tratado aca… va miré asi nomas pero en fin.

Como algunos sabrán el ICH9 normal no ofrece AHCI, sólo modo IDE normal. (pueden fijarse en
administrador de dispositivos como les aparece el disco.. generalmente como 2 canal ide principal y 2 canal ide secundario por cada HDD) Por lo que perderiamos las funciones que nos ofrece para nuestros discos sata.

El modo SATA-AHCI presenta algunas mejoras de rendimiento respecto al SATA-IDE

INTEL saco esa modalidad y supuestamente da muchas mejoras en los SATA las cuales textualmente son las siguientes:

"El modo AHCI (Advanced Host Controller Interface) controla las características avanzadas de la controladora SATA, entre ellas el NCQ (Native Command Queuing). El modo NCQ es un modo de búsqueda de datos propio sólo de los discos SATA (que lo soporten) que permite un acceso más rápido a la información, ya que en lugar de acceder a la información en el orden de búsqueda que le damos, accede a ella en el orden en que está grabada en la superficie del disco duro, minimizando el movimiento de la cabeza lectora, la espera y el desgaste del sistema."

La conexión en caliente de dispositivos, activación de un led de actividad del dispositivo, multiplicador de puertos Serial ATA, direccionamiento de 64 bits*, soporte LBA para dispositivos de muy alta capacidad, administración de energía, etc.
En sistemas de 64bits el AHCI hace uso de capacidades de acceso directo a la memoria del sistema

Por ejemplo en el mother Gigabyte P35-DS3L en el bios aparece la funcion para habilitar el modo AHCI (aunque en este mobo no deberia funcionar segun lei, funciona) peeero windows xp no tiene los controladores para que este modo funcione por lo que si cambiamos a ahci e iniciamos windows pantallazo azul…

Como no tengo ahora forma de mostrarles fotos mias, pongo las que encontre para que se guíen mejor:

Aquí dentro en la primera opcion aparece para activar el modo AHCI de nuestro disco sata

Pero vayamos por pasos.

Antes que nada hace un punto de restauracion por las dudas (yo no lo hice ) igual si te tira pantalla azul apreta F8 antes de entrar y elegi "Entrar con la ultima configuaracion exitosa" o algo asi y lesto (no vas a perder datos ni nada de eso)

1- Bajate este archivo que contiene los controladores para XP: http://www.mediafire.com/?z1ucwg09oxn

2- Extraé el contenido del .rar en alguna parte

3- Copia los archivos iaStor.inf + iaStor.sys en tu carpeta "WINDOWS\System32\Drivers"

4- Despues de copiar los archivos, ejecuta (doble click) en el archivo llamado iaStor.reg (el icono del archivo suele ser una hoja con un cubo magico azul )

5- Reinicia y cambia en bios al modo AHCI

6- Si entra a windows felicidades hiciste todo bien!! Ahora dejalo un ratito al guindou a que detecte el "nuevo" disco que tenes y te va a pedir instalar los controladores, no cerres el asistente, elegi "seleccionar manualmente" > "Utilizar Disco" y abri el archivo llamado iaahci.inf instalas y te pide reiniciar.

7- Si no se te congelo windows felicidades ya tenes tu disco sata funcionando! sino… volve a repetir los pasos y esta vez hacelos bien! je

Espero les haya servido la guia… no muy detallada y quizas descuidada en palabras pero…

EDIT: Estuve haciendo unos benchs, los resultados son muy variables pero dentro de todo quedan parejos los discos… puse las imagenes en orden SATA-IDE vs SATA-AHCI con los mismos subprocesos debajo para que no afecte la medicion que ya bastante desprolija és..

Empezando con el programita Boot Time

Seguimos con el ATTO Disk Benchmark v2.02

Ahora el HD Tach v3.0.4.0

Drive Speed Checker

FC Test – Creacion de archivos ISOs (imagenes de cd)

FC Test – Creacion de 414 Archivos

Como se podrá ver, las diferencias no son tan grandes en la mayoria de las pruebas, en modo ahci la velocidad de escritura aumenta bastante y disminuye un poco la de lectura, aunque no encontre forma de medir el desempeño al buscar archivos del sistema, en modo ahci mejora bastante. En el booteo medio raro… hasta hace poquito cuando lo habia probado habia mucha diferencia jeje parece que fue suerte nada mas.

Queria introducir el Sisoft sandra pero por alguna razon no se iniciaba… despues el everest pero bué no daba para cambiar de modo otra vez ya con esto que puse es mucho seguramente en otros discos rigidos el desempeño es diferente al mio prueben ustedes!

NOTA: Si van a usar el modo AHCI desactiven el modo Sata Port 0-3 Native Mode

Hardcore Extreme Level

ivan quaglia

entradas: 14363

02:21 20/05/2008

2

interesante che, tengo en la mira este mobo… muejejejej.. gracias!!!!!!!!!!!

Midle End Level

marcosaris

entradas: 452

05:56 20/05/2008

3

Que funciones ganamos con este metodo?, mejoras?

High End Level

BiFa

entradas: 764

09:49 20/05/2008

4
Cita Iniciado por marcosaris
Ver Mensaje
Que funciones ganamos con este metodo?, mejoras?

El modo SATA-AHCI presenta algunas mejoras de rendimiento respecto al SATA-IDE

INTEL saco esa modalidad y supuestamente da muchas mejoras en los SATA las cuales textualmente son las siguientes:

"El modo AHCI (Advanced Host Controller Interface) controla las características avanzadas de la controladora SATA, entre ellas el NCQ (Native Command Queuing). El modo NCQ es un modo de búsqueda de datos propio sólo de los discos SATA (que lo soporten) que permite un acceso más rápido a la información, ya que en lugar de acceder a la información en el orden de búsqueda que le damos, accede a ella en el orden en que está grabada en la superficie del disco duro, minimizando el movimiento de la cabeza lectora, la espera y el desgaste del sistema"

Al menos en las busquedas de archivos la mejora es notable y en el arranque del sistema tarda menos, despues en otras cosas no se ve mucha mejora pero la velocidad general es mayor

Hardcore Extreme Level

010101

Reconquista, Santa Fe

entradas: 6759

10:11 20/05/2008

5

y esta comprobado que tiene mas rendimiento que el sata ide? por q de las palabras a los echos …..hay un largo camino mas en informatica………..

High End Level

BiFa

entradas: 764

10:30 20/05/2008

6
Cita Iniciado por 010101
Ver Mensaje
y esta comprobado que tiene mas rendimiento que el sata ide? por q de las palabras a los echos …..hay un largo camino mas en informatica………..

No tengo pruebas que lo demuestren, solo la experiencia que tuve al cambiar de modo, al principio pensaba lo mismo, pero el arranque de windows es mucho mas rapido y en las busquedas de archivos la mejora es notoria, despues quizas en mover archivos y demas puede ser que sea mas rapido no tuve tiempo a probar eso, pero mientras aporte 1 mejora para mi es bienvenido el cambio

Extreme Level

Actuario

entradas: 1617

11:02 20/05/2008

7

A ver si se puede generar un bench que compare realmente las mejoras !! ánimos BiFa !! y gracias por la noticia !!

Hardcore Extreme Level

Mr. X

Hudson, Berazategui

entradas: 5616

11:06 20/05/2008

8
Cita Iniciado por Actuario
Ver Mensaje
A ver si se puede generar un bench que compare realmente las mejoras !! ánimos BiFa !! y gracias por la noticia !!

Ahbia un test dando vueltas en el foro. Muy grata la noticia!

Extreme Level

djthanatos

entradas: 1024

11:30 20/05/2008

9

Muchas graciasss hace tiempo que buscaba hacer uso del SATA AHCI en XP, ya que solo se puede usar en Vista.

Samsung 226BW 22" @ 1680x1050 DVI * EVGA e-GeForce 8800GT 512MB * Core2Quad Q9550 + Zalman CNPS9500 AT * ASUS P5Q-E * 8Gb Corsair Dominator 1066Mhz PC2-8500 C5 * Creative X-Fi Extreme Fidelity Elite Pro * 300Gb WD Velociraptor & 3x750Gb Seagate Barracuda RAID0 * Pinnacle Studio MovieBoard Plus 700 * Cooler Master Real Power Pro 750W * CM690 * UPS Forza 750W

High End Level

BiFa

entradas: 764

12:34 20/05/2008

10

Ahora en un rato busco las herramientas y subo los bench

Extreme Level

miguecasla

entradas: 1499

13:13 20/05/2008

11

Yo hize lo mismo en mi mobo, y ahora si le conecto un HD IDE la pc no arranca, si le conecto un DVD-RW no hay drama, sera por el controlador que tiene?

High End Level

BiFa

entradas: 764

13:29 20/05/2008

12
Cita Iniciado por miguecasla
Ver Mensaje
Yo hize lo mismo en mi mobo, y ahora si le conecto un HD IDE la pc no arranca, si le conecto un DVD-RW no hay drama, sera por el controlador que tiene?

mmmm quizas… no tengo uno ide para probar lamentablemente, hay que toketear opciones y ver

Hardcore Extreme Level

Radamanthys

entradas: 3228

13:55 20/05/2008

13

Buena guia , Mejora la performance ? Yo no puedo probarlo porq estoy con Raid 0 en mi maquina

1055T @ 3.9Ghz 1.45v – 2x2Gb G.Skill Trident @1600 8-8-8-20 1T- Evga GTX460 SC @ 830 / 2000 – 2Tb + 80Gb S.O. – OCZ Fatality 750W – Dell S2409W – LC K-62 DarkIce
Xbox 360 NTSC – Jasper V3 – Modded – Ixtreme LT 1.1 – HD 250Gb

High End Level

BiFa

entradas: 764

14:48 20/05/2008

14

benchs echos y subidos tarde como 2 horas en todo el proceso ¬¬

Extreme Level

NickOS

entradas: 1137

00:01 21/05/2008

15

y este mobo no me deja de sorprender! Ivan cada vez tenes un motivo mas para comprar el mobo, vende rapido y pasate al lado heavy (h)

BIFAAAA muchas gracias che.. todavia no puedo asegurar un cambio de rendimiento notable pero funcionar funciona el mdo AHCI

Midle End Level

UnknownSoldier

entradas: 411

00:02 21/05/2008

16

Muy buen trabajo! Felicitaciones!

Hardcore Extreme Level

010101

Reconquista, Santa Fe

entradas: 6759

18:41 21/05/2008

17

disculpa que vercion de bios tenes ya que la tengo yo al activar esta optcion, cada vez que arranca la pc me aparece una utilidad de la bios diciendo que este metodo solo es para hdds y dvds y bueno y me dice detectando los discos estos puede demorar unos segundos………….pero esta como 10 segundos o mas y la verdad que de ser asi este es mejor como antes nomas me domoraba menos ingresar la pc a windows.

Extreme Level

NickOS

entradas: 1137

22:32 21/05/2008

18
Cita Iniciado por 010101
Ver Mensaje
disculpa que vercion de bios tenes ya que la tengo yo al activar esta optcion, cada vez que arranca la pc me aparece una utilidad de la bios diciendo que este metodo solo es para hdds y dvds y bueno y me dice detectando los discos estos puede demorar unos segundos………….pero esta como 10 segundos o mas y la verdad que de ser asi este es mejor como antes nomas me domoraba menos ingresar la pc a windows.

adhiero al caballero binario, me pasa lo mismo pense que era normal y tambien me molesta esa pantalla de booteo, por cierto en el hd tach me siggue dando mismo score que cuando no tenia habilitado el AHCI
grasia

Hardcore Extreme Level

010101

Reconquista, Santa Fe

entradas: 6759

23:02 21/05/2008

19
Cita Iniciado por NickOS
Ver Mensaje
adhiero al caballero binario, me pasa lo mismo pense que era normal y tambien me molesta esa pantalla de booteo, por cierto en el hd tach me siggue dando mismo score que cuando no tenia habilitado el AHCI
grasia

A mi me dio menos ja bueno espero respuestas !

High End Level

BiFa

entradas: 764

10:05 22/05/2008

20
Cita Iniciado por 010101
Ver Mensaje
disculpa que vercion de bios tenes ya que la tengo yo al activar esta optcion, cada vez que arranca la pc me aparece una utilidad de la bios diciendo que este metodo solo es para hdds y dvds y bueno y me dice detectando los discos estos puede demorar unos segundos………….pero esta como 10 segundos o mas y la verdad que de ser asi este es mejor como antes nomas me domoraba menos ingresar la pc a windows.

Cita Iniciado por NickOS
Ver Mensaje
adhiero al caballero binario, me pasa lo mismo pense que era normal y tambien me molesta esa pantalla de booteo, por cierto en el hd tach me siggue dando mismo score que cuando no tenia habilitado el AHCI
grasia

tranquilos tranquilos! tengo la version F8a o algo asi ya no me olvide je, con respecto a lo del booteo es verdad demora 10 segundos clavados, pero a mi no me jode ya que reinicio una vez por semana mas o menos

Los test son muy variables por desgracia si los pasas 50 veces da 50 diferentes resultados, algunos muy buenos otros malos psss….

si les jode desactivenlo total no es "LA" diferencia en rendimiento

Extreme Level

NickOS

entradas: 1137

10:08 22/05/2008

21
Cita Iniciado por BiFa
Ver Mensaje
tranquilos tranquilos! tengo la version F8a o algo asi ya no me olvide je, con respecto a lo del booteo es verdad demora 10 segundos clavados, pero a mi no me jode ya que reinicio una vez por semana mas o menos

Los test son muy variables por desgracia si los pasas 50 veces da 50 diferentes resultados, algunos muy buenos otros malos psss….

si les jode desactivenlo total no es "LA" diferencia en rendimiento

Pero teniendo la f8 hace algun cambio en benchmark o la transferencia de datos?
yo te lo digo por que tengo la que me vino con la mobo que es la F3..

High End Level

BiFa

entradas: 764

10:16 22/05/2008

22
Cita Iniciado por NickOS
Ver Mensaje
Pero teniendo la f8 hace algun cambio en benchmark o la transferencia de datos?
yo te lo digo por que tengo la que me vino con la mobo que es la F3..

La verdad que no se, cuando compre el mobo le actualize la bios al toke, supongo que seria lo mismo con cualquier version de bios, creo que la unica forma de probar si es mejor (obviando los bench) ahora voy a hacer unas pruebas con medicion a reloj a ver si el test manual da otros resultados

Extreme Level

NickOS

entradas: 1137

10:57 23/05/2008

23
Cita Iniciado por BiFa
Ver Mensaje
La verdad que no se, cuando compre el mobo le actualize la bios al toke, supongo que seria lo mismo con cualquier version de bios, creo que la unica forma de probar si es mejor (obviando los bench) ahora voy a hacer unas pruebas con medicion a reloj a ver si el test manual da otros resultados

que paso con eso bifa?

Extreme Level

miguecasla

entradas: 1499

11:29 23/05/2008

24

Anoche probe con el disk Bench del Everest, y la verdad en algunos casos me tiro mejores numeros con el controlador comun o sea el IDE, lo unico que bajo en toque fue el Bufered reading creo, despues en los demas me tiro numeros mejores.

Siempre hablando del ICH9R, que es el que yo tengo.

High End Level

BiFa

entradas: 764

12:33 23/05/2008

25
Cita Iniciado por NickOS
Ver Mensaje
que paso con eso bifa?

Surgio algo en el dia y no pude hacer nada. Pero aca tá

Las pruebas fueron las siguientes, a reloj midiendo el tiempo entre cada modo, nada de programitas benchgarc

Copiado de una imagen ISO de 3.58 GB (el dvd 1 del NFS ProStreet)
AHCI > 1min 48seg vs 2min 32seg < IDE

Copiado de 374 Archivos de fotos con 14 carpetas, tamaño 128 MB
AHCI > 14seg vs 21seg < IDE

Copiado de 573 Archivos MP3 y 34 Archivos de fotos con 34 carpetas, tamaño 1.03 GB (discografia de tangalanga)
AHCI > 44seg vs 1min 06seg < IDE

Extraccion con WinRAR de archivo ISO de 3.58 GB (el dvd 1 del NFS ProStreet)
AHCI > 4min 32seg vs 4min 02seg < IDE

Otras pruebas no se me ocurren, ya que lo que mas hace el disco es copiar cosas, faltaria la instalacion de un juego a ver… quizas mas tarde pongo uno, tengo el DIRT para instalar mmmm…

Extreme Level

NickOS

entradas: 1137

12:38 23/05/2008

26
Cita Iniciado por BiFa
Ver Mensaje
Surgio algo en el dia y no pude hacer nada. Pero aca tá

Las pruebas fueron las siguientes, a reloj midiendo el tiempo entre cada modo, nada de programitas benchgarc

Copiado de una imagen ISO de 3.58 GB (el dvd 1 del NFS ProStreet)
AHCI > 1min 48seg vs 2min 32seg < IDE

Copiado de 374 Archivos de fotos con 14 carpetas, tamaño 128 MB
AHCI > 14seg vs 21seg < IDE

Copiado de 573 Archivos MP3 y 34 Archivos de fotos con 34 carpetas, tamaño 1.03 GB (discografia de tangalanga)
AHCI > 44seg vs 1min 06seg < IDE

Extraccion con WinRAR de archivo ISO de 3.58 GB (el dvd 1 del NFS ProStreet)
AHCI > 4min 32seg vs 4min 02seg < IDE

Otras pruebas no se me ocurren, ya que lo que mas hace el disco es copiar cosas, faltaria la instalacion de un juego a ver… quizas mas tarde pongo uno, tengo el DIRT para instalar mmmm…

a mejora bastante el nivel de escritura, ahora deshabilito el ACHI y hago los mismos testeos si veo que no me funciona es por la version del bios o el HD

High End Level

BiFa

entradas: 764

10:31 24/05/2008

27
Cita Iniciado por NickOS
Ver Mensaje
a mejora bastante el nivel de escritura, ahora deshabilito el ACHI y hago los mismos testeos si veo que no me funciona es por la version del bios o el HD

dale despues conta, pero aclara cual HD estas usando y los MB de buffer para saber que puede ser que haga diferencia (el mio es el de mi perfil)

Extreme Level

Lukas17

Córdoba

entradas: 1028

13:35 24/05/2008

28

Una pregunta… sirve esto para el Intel (ICH8) de mi Gigabyte 965P-DS3??? Gracias…

Core 2 Duo E6600 @3.2Ghz + Xigmatek HDT-S1283 // 2x1GB OCZ SLI-Ready Edition 800Mhz Lat. 4-4-4-12 // ATI Shappire HD4870 512MB GDDR5 // Samsung 2253NW // Gigabyte 965P-DS3 // Topower 580W P5-EZ Plugin // Sound Blaster Audigy SE M@D X-Fi Xtreme Audio + Edifier X400 // Cooler Master 690 // A4tech X-750F
Notebook Compaq Presario CQ40-305LA
High End Level

BiFa

entradas: 764

21:26 24/05/2008

29
Cita Iniciado por Lukas17
Ver Mensaje
Una pregunta… sirve esto para el Intel (ICH8) de mi Gigabyte 965P-DS3??? Gracias…

Si deberia servir, si tu mother tiene la opcion para poner modo ahci en bios, cuando te detecta el disco sata al elegir el controlador a instalar aparecen los modelos y el tuyo esta en la lista si mal no recuerdo

Nuevo miembro

juanicana

entradas: 5

19:45 25/05/2008

30

gente, yo no tengo la opcion de "SATA AHCI Mode en la bios del mother
tengo un msi p35 neo.
es ich9 mi chip.
Ya instale los drivers, registre todo. pero desde el mother solo puedo poner, ide o disable. digamos que la parte de integrate peripehal tiene muchas menos opciones que la de la foto.
saludos
Juani